Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 01, 2025 - 19:00 CDT
Scheduled
Euna Special Ed will be unavailable starting Friday, August 1st at 7:00 PM CDT for scheduled maintenance — because even systems need a little professional development! Maintenance may extend through Sunday, August 3rd, but the system will be fully operational before the start of the workday on Monday.
Posted Jul 30, 2025 - 10:59 CDT
This scheduled maintenance affects: Euna Special Ed Systems (Euna Special Ed Web Application, Euna Special Ed Integration).